<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"r0H803221Fcfzr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"ksla"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "ksla/web/news/top-story",
    "authors": [
                  
                    {
                      "_id": "rob-masson",
                      "name": "Rob Masson",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2019/06/27/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/",
    "contentId": "TAXET34EV5D7ZEKCST2IOWZNWU",
    "contentName": "New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison",
    "contentOwner": "wvue",
    "contentTags":  [
                  
                    {
                      "text": "Royal Clark",
                      "description": "Royal Clark",
                      "slug": "royal-clark"
                    },
                  
                    {
                      "text": "Innocence Project",
                      "description": "Innocence Project",
                      "slug": "innocence-project"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2019-06-27T21:37:25.657Z",
    "description": "A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence.",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": "false",
    "metaDescription": "A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Top Story",
                            "_id": "/news/top-story",
                            "path": "/news/top-story",
                          }
                        
                      ,
    "publishedDay": "27",
    "publishedMonth": "06",
    "publishedYear": "2019",
    "stationName": "ksla",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="vUq_uEG44EbU3FtYSqRgQsmgX1oStPTCAS9xdsKgS-c"/> <title>New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison</title> <meta name="keywords" content="exoneration, fingerprint database"> <meta name="news_keywords" content="exoneration, fingerprint database"/> <meta name="date" content="2019-06-27T21:37:26.928Z"/> <meta itemprop="description" name="description" content="A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.ksla.com/2019/09/09/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/"> <meta name="twitter:title" content="New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison"/> <meta name="twitter:image" content="https://www.ksla.com/resizer/1O9vrEuQYajxNoPJ9TzRUqnSTcM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZQCQOPIMORBHRDUCN2RVRGO7XM.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence."/> <meta name="twitter:site" content="@KSLA"/> <meta name="twitter:creator" content="@KSLA"> <meta property="og:url" content="https://www.ksla.com/2019/09/09/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/"/> <meta property="og:title" content="New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison"/> <meta itemprop="image" property="og:image" content="https://www.ksla.com/resizer/1O9vrEuQYajxNoPJ9TzRUqnSTcM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZQCQOPIMORBHRDUCN2RVRGO7XM.jpg"/> <meta property="og:description" content="A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.ksla.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="435382783232854"/> <meta property="fb:pages" content="99664861499"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/KSLANews12"> <meta property="article:tag" content="Royal Clark, Innocence Project"> <link rel="amphtml" href="/2019/09/09/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/?outputType=amp"> <meta name="author" content="Rob Masson"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.ksla.com/resizer/1O9vrEuQYajxNoPJ9TzRUqnSTcM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZQCQOPIMORBHRDUCN2RVRGO7XM.jpg",
          "height": 1512.0,
          "width": 1200
        },
        
        "datePublished": "2019-09-09T01:47:53.529Z",
        "dateModified": "2019-06-27T21:37:26.928Z",
        "articleBody": "NEW ORLEANS, La. (WVUE) - A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence.On one of the hottest days of the year, fresh air was never so sweet for Royal Clark.Sixteen years after he was convicted for a 2001 Terrytown armed robbery of a Burger King, Clark walked free for the first time, and into the arms of his emotional family.“I didn’t know I would see this moment...didn’t think I would ever see these streets again,” said Clark.At his side...a 17-year-old son...who has been craving a Dad.“Growing up without a father...for 17 years...it was hard..my mama couldn’t always be there for me, she had to work,” said Royal Clark III.Clark’s freedom was made possible by the Innocence Project New Orleans and the Jefferson Parish District Attorneys office which recently allowed Clark’s attorneys to view other fingerprints taken from the scene of the crime.“This is an indication of the need for prisoners to have access to fingerprint databases, right now, they don’t have one,” said attorney Kia Hall Hays, with the Innocence Project New Orleans (IPNO).The newly uncovered fingerprints implicated another man who looked like Clark and was convicted of committing a string of similar Westbank robberies during the same timeframe.“I can’t be angry, because if I let myself be angry it would cloud my views on life,” said Royal Jr.No one knows for sure how many other cases like Clark’s are out there but the Innocence Project New Orleans (IPNO) wants laws changed so that convicts have full access to fingerprint data bases.“I think it’s clear that this state needs a statute that allows anyone in prison to have the right to go to court and request that,” said Emily Maw, with IPNO.Clark looks forward to catching up with a son born the year he went to jail.&#034;I want to enjoy my company with my new family...and get some crawfish, and chill out,&#034; said Clark..And he says at 42-years-old, if he stays focused, he believes he will succeed outside of prison walls.“Y’all gave me a second chance.. to show my innocence...and I’m proud to be out here,” said ClarkRoyal Clark was convicted on a 10-2 jury vote, which is no longer allowed in Louisiana. He is the second person to be released in this state after new fingerprint evidence was made available through a state database.Copyright 2019 WVUE. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Rob Masson"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "https://www.ksla.com",
        "logo": "https://www.ksla.com/pb/resources/images/rm_icons/ksla-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/KSLANews12" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/027f0179ca5efc879509/rm/rm-framework027f0179ca5efc879509.css?v=76" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/ksla-logo.svg?v=76)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/ksla-logo.svg?v=76)}</style> <link href="/pb/resources/dist/027f0179ca5efc879509/rm/rm-framework027f0179ca5efc879509.css?v=76" rel="stylesheet"/> <link href="/pb/resources/dist/027f0179ca5efc879509/rm/rm-features027f0179ca5efc879509.css?v=76" rel="stylesheet"/> <link href="/pb/resources/dist/027f0179ca5efc879509/rm/rm-services027f0179ca5efc879509.css?v=76" rel="stylesheet"/> <script src="/pb/gr/c/default/r0H803221Fcfzr/arcAdsJS/cdbd7d78da.js?v=76"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="f06hqQB21Fcfzr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.ksla.com/childrens-miracle-network/" class="color-grey-dark">CMN Miracle Monday</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.ksla.com/community/yokem-connection/" class="color-grey-dark">Yokem Connection</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.ksla.com/video-gallery/community/prize-fest/" class="color-grey-dark">Prize Fest</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f4EkB6221Fcfzr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0xmsW121Fcfzr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.ksla.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/homepage" class="">Home</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.ksla.com/live" class="color-white">Watch Live</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.ksla.com/roku" class="color-white">Watch on Roku & Amazon Fire</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/user-content" class="color-white">See it, Snap It, Send It</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/politics" class="color-white">Politics</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/investigate" class="color-white">KSLA Investigates</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/crime" class="color-white">CrimeTracker</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/spending-smarter" class="color-white">Spending Smarter</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/keeping-you-safe" class="color-white">Keeping You Safe</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/news/the-good-stuff" class="color-white">The Good Stuff</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/editorial" class="color-white">Editorial</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="http://www.ksla.com/apps" class="color-white">Download apps</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/weather/hurricane" class="color-white">Hurricane Center</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.ksla.com/live" class="color-white">Severe Weather Coverage</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://ksla.com/backtoschool" class="color-white">Back to School Guide</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/community/ksla-cafe" class="color-white">KSLA Cafe</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/salutes" class="color-white">KSLA Salutes</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/community/yokem-connection" class="color-white">Yokem Connection</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/community/your-hometown-show" class="color-white">Your Hometown Show</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.ksla.com/boost/" class="color-white">KSLA Business Boost</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/community/worship" class="color-white">KSLA Worship Directory</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="http://www.ksla.com/childrens-miracle-network/" class="color-white">Childrens Miracle Network</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="/community/calendar" class="color-white">Calendar</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.ksla.com/sports/athlete-of-the-week/" class="color-white">Lander's Athlete of the Week</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming" class="color-white">TV</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.ksla.com/team" class="color-white">Meet the Team</a> </div> </div> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0IkBki21Fcfzr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-ksla-breaking/" data-url="/pb/api/v2/render/feature" data-website="ksla" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fMljIZ121Fcfzr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/ksla-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="ksla"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fneEBa121Fcfzr"> <div id="ad92-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad92" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad92",slotName:"ksla/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"TAXET34EV5D7ZEKCST2IOWZNWU"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f8Gm8f221Fcfzr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.ksla.com/news/crime"> CrimeTracker </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="New fingerprint evidence allows Jeff Parish man to walk free after 17 years in prison" src="https://www.ksla.com/resizer/plWUcOFU4RpNxwmw4Z6VhMG0YpA=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZQCQOPIMORBHRDUCN2RVRGO7XM.jpg"/> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="cCQ5u9121Fcfzr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=New+fingerprint+evidence+allows+Jeff+Parish+man+to+walk+free+after+17+years+in+prison&amp;url=https%3A%2F%2Fwww.ksla.com%2F2019%2F09%2F09%2Fnew-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ksla.com%2F2019%2F09%2F09%2Fnew-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison%2F&amp;title=New+fingerprint+evidence+allows+Jeff+Parish+man+to+walk+free+after+17+years+in+prison', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=New%20fingerprint%20evidence%20allows%20Jeff%20Parish%20man%20to%20walk%20free%20after%2017%20years%20in%20prison&amp;body=Read%20more%20on%20New%20fingerprint%20evidence%20allows%20Jeff%20Parish%20man%20to%20walk%20free%20after%2017%20years%20in%20prison%20at%20https%3A%2F%2Fwww.ksla.com%2F2019%2F09%2F09%2Fnew-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0MhLg221Fcfzr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/rob-masson/"> <span class="font-bold ">Rob Masson</span></a> <span class="font-bold">|</span> <span class="timestamp"> June 27, 2019 at 4:37 PM CDT - Updated September 8 at 8:47 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0HqVJb21Fcfzr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>NEW ORLEANS, La. (WVUE) - A Jefferson Parish man and his family are thrilled today that after 17 years behind bars, he’s a free man. Royal Clark Jr. walked out of the Gretna jail, thanks to newly uncovered evidence.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>On one of the hottest days of the year, fresh air was never so sweet for Royal Clark.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Sixteen years after he was convicted for a 2001 Terrytown armed robbery of a Burger King, Clark walked free for the first time, and into the arms of his emotional family.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“I didn’t know I would see this moment...didn’t think I would ever see these streets again,” said Clark.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1381-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1381" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1381",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>At his side...a 17-year-old son...who has been craving a Dad.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Growing up without a father...for 17 years...it was hard..my mama couldn’t always be there for me, she had to work,” said Royal Clark III.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Clark’s freedom was made possible by the Innocence Project New Orleans and the Jefferson Parish District Attorneys office which recently allowed Clark’s attorneys to view other fingerprints taken from the scene of the crime.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad1070-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1070" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1070",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“This is an indication of the need for prisoners to have access to fingerprint databases, right now, they don’t have one,” said attorney Kia Hall Hays, with the Innocence Project New Orleans (IPNO).</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad346-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad346" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad346",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The newly uncovered fingerprints implicated another man who looked like Clark and was convicted of committing a string of similar Westbank robberies during the same timeframe.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“I can’t be angry, because if I let myself be angry it would cloud my views on life,” said Royal Jr.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>No one knows for sure how many other cases like Clark’s are out there but the Innocence Project New Orleans (IPNO) wants laws changed so that convicts have full access to fingerprint data bases.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“I think it’s clear that this state needs a statute that allows anyone in prison to have the right to go to court and request that,” said Emily Maw, with IPNO.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1105-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1105" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1105",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Clark looks forward to catching up with a son born the year he went to jail.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"I want to enjoy my company with my new family...and get some crawfish, and chill out," said Clark..</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad397-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad397" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad397",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>And he says at 42-years-old, if he stays focused, he believes he will succeed outside of prison walls.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Y’all gave me a second chance.. to show my innocence...and I’m proud to be out here,” said Clark</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad338-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad338" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad338",slotName:"ksla/web/news/top-story/TAXET34EV5D7ZEKCST2IOWZNWU",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Royal Clark was convicted on a 10-2 jury vote, which is no longer allowed in Louisiana. He is the second person to be released in this state after new fingerprint evidence was made available through a state database.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2019 WVUE. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fJYaN4121Fcfzr"> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f05ihVh21Fcfzr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.ksla.com/2019/06/27/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.ksla.com/2019/06/27/new-fingerprint-evidence-allows-jeff-parish-man-walk-free-after-years-prison/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fv7uoh121Fcfzr"> <div id="ad1409-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1409" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1409",slotName:"ksla/web/news/top-story",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"TAXET34EV5D7ZEKCST2IOWZNWU"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="fW7ZTr121Fcfzr"> <div class="invisible weather-gradient flex-grid color-white pb-weather night" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="night-clear" data-default-location-code="USLA0426" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="ksla" data-location-code="USLA0426" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USLA0426,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.ksla.com/weather"> <img class="radar-image" src="https://webpubcontent.raycommedia.com/ksla/weather/currentloop.gif" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="85" data-temp-c="29"> 85</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/97_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Shreveport, LA</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.ksla.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad355-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad355" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad355",slotName:"ksla/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="fXYV6G121Fcfzr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Rob Masson" data-src="https://www.ksla.com/resizer/d-t6k4TZGtPNYJ1xnkQ7ahQDbGw=/1400x0/s3.amazonaws.com/arc-authors/raycom/1fc49115-afdf-4666-ac65-cc34aad63d85.png" src="https://www.ksla.com/resizer/f2HlgSMDZmVvFAirkypBZ8K-7Vo=/0x10/s3.amazonaws.com/arc-authors/raycom/1fc49115-afdf-4666-ac65-cc34aad63d85.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/rob-masson/"> <h3 class="promo-header">Rob Masson</h3> </a> <h4 class="hidden font-normal color-grey-dark"></h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-xs"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/robmassonfox8" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://www.facebook.com/rob.massonwvue" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:rmasson@fox8live.com?subject=New%20fingerprint%20evidence%20allows%20Jeff%20Parish%20man%20to%20walk%20free%20after%2017%20years%20in%20prison&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">FOX 8 reporter Rob Masson began his broadcasting career while in college as News Director at WLSU. This Louisiana State University grad has been covering news in New Orleans since the mid-eighties, and has been with FOX 8 since 1994.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="f0w2Uq221Fcfzr"> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0hry1e21Fcfzr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fsYS6Z121Fcfzr"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-182688" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/09/08/rescued-missing-after-cargo-ship-tips-off-georgia-coast/"> <img class="width-full " alt="20 rescued, 4 missing after cargo ship tips off of Georgia coast" src="https://www.ksla.com/resizer/C87Kqh71Vn6i8SMQPfmqwO4I38Y=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/C765Y3MZCRDDPMDMVEOS4OZRAA.bmp"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/08/rescued-missing-after-cargo-ship-tips-off-georgia-coast/"> 20 rescued, 4 missing after cargo ship tips off of Georgia coast</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">The United States Coast Guard is working to help the crew of the Golden Ray after the vessel tipped on its side in the Port of Brunswick.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Zach Logan&nbsp;and</span></span> <span><span>Bradley Mullis</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/09/09/instagrammable-theyre-getting-outrageous-about-pizza/"> <img class="width-full " alt="Instagrammable: They’re getting outrageous about pizza" src="https://www.ksla.com/resizer/2sVNSlkdFMZMoAcXX0SPEzk2Mo8=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/76XPKZ77EVFMPIMJ32NZZ45IOY.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/09/instagrammable-theyre-getting-outrageous-about-pizza/"> Instagrammable: They’re getting outrageous about pizza</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Over-the-top creations are a social media sensation delivering new customers to restaurants eager for a slice of the action</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0eMEbE21Fcfzr"> <div id="ad1526-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1526" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1526",slotName:"ksla/web/news/top-story",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"TAXET34EV5D7ZEKCST2IOWZNWU"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c08Naks21Fcfzr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0dwCRB21Fcfzr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-87678" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/09/08/man-allegedly-drove-stolen-truck-miles-flat-tire/"> <img class="width-full " alt="Man allegedly drove stolen truck for miles on a flat tire " src="https://www.ksla.com/resizer/ROacDxkpkJfBbr9I68hlm6v32s8=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/Q2BMVY7DZJB2VP4VR6SDL5WNBY.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/08/man-allegedly-drove-stolen-truck-miles-flat-tire/"> Man allegedly drove stolen truck for miles on a flat tire </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>KSLA Digital Team</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 3h at 6:59 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/09/08/infant-toddler-die-house-fire/"> <img class="width-full " alt="Infant, toddler die in house fire" src="https://www.ksla.com/resizer/Ejke43tY9EQ9qJgYk1RQjShHSbk=/12x0:924x684/912x684/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/M6O43MKBAJHA5P5JHGXW7WB45A.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/08/infant-toddler-die-house-fire/"> Infant, toddler die in house fire</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>KSLA Digital Team</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 4h at 5:48 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/09/08/pickup-hits-man-riding-lawn-mower-killing-him/"> <img class="width-full " alt="Pickup hits man riding lawn mower, killing him" src="https://www.ksla.com/resizer/GxeCxiJHge1PcansPXJ1hC4M2BQ=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GWJEXJXKE5ED5LGRZTSZBDQ5X4.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/08/pickup-hits-man-riding-lawn-mower-killing-him/"> Pickup hits man riding lawn mower, killing him</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>KSLA Digital Team</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 4h at 5:09 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/09/08/north-alabama-school-removes-bathroom-stall-doors-combat-vaping/"> <img class="width-full " alt="North Alabama school removes bathroom stall doors to combat vaping" src="https://www.ksla.com/resizer/kb_Csu3JSyeY_zpeGxzd7Xh5ykQ=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CJR5FAYZN5A4PNMOH2I527JP44.bmp"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/09/08/north-alabama-school-removes-bathroom-stall-doors-combat-vaping/"> North Alabama school removes bathroom stall doors to combat vaping</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Levi Harvey</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 12:35 PM at 12:35 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fpaHBk221Fcfzr"> <div id="ad1385-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1385" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1385",slotName:"ksla/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"TAXET34EV5D7ZEKCST2IOWZNWU"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="f0j1R2D21Fcfzr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.ksla.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 1812 Fairfield Ave.<br/>Shreveport, LA 71101<br/>(318) 222-1212 </p> <a class="call-to-action uppercase color-white" href="http://www.ksla.com/about-us/">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/ksla" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@ksla.com" class="color-white">publicfile@ksla.com<br/>(318) 222-1212</a></li> <li><a href="http://webpubcontent.raycommedia.com/ksla/pdf/ksla-eeo.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.ksla.com/story/12029771/questions-or-complaints-about-closed-captioning" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KSLA Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KSLA" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/KSLANews12" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/ksla" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@ksla.com" class="color-white">publicfile@ksla.com<br/>(318) 222-1212</a></li> <li><a href="http://webpubcontent.raycommedia.com/ksla/pdf/ksla-eeo.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.ksla.com/story/12029771/questions-or-complaints-about-closed-captioning" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KSLA Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KSLA" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/KSLANews12" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/r0H803221Fcfzr/render.js?v=76'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/027f0179ca5efc879509/rm/rm-index027f0179ca5efc879509.js"></script>